Sportbike Forums on WristTwisters banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey all first time poster been in the hole for 2 weeks trying to get this 04 919 to start I road it home from work and as soon as my front tire hit the driveway the bike just turned off like I had hit the kill switch I checked the tank seemed very low on gas not no fuel low light came on nor did the FI light come on so I added about a gallon or 2 and nothing the bike just cranks and sometimes makes some noise out of the exhaust the fuel pump primes I pulled the plugs they were nasty but all sparked and I replaced them all still nothing only thing I can think of if the injections aren’t firing any ideas anyone?
 

·
Wanna free cat?
Joined
·
1,020 Posts
 

·
McTavish
Joined
·
6,416 Posts
Was anything recently done to the bike?
If so, revisit the work done.

Not nearly enough is presently known to diagnose.
From your description, my guess is that ignition might be involved, on the basis of the fuel pump spooling up to make fuel rail pressurized fuel available at the injectors, thus suggesting there is fuel available.
I'd try using one of your spare plugs to check for spark at the two easy to access outer cylinders. (remove the high tension lead and fasten to the spare plug, and ground the test plug to check for spark)

Rufftup has sent you a link to the FSM.
Even if your FI light hasn't lit, you should still check to see if any codes are stored.
See section 5 of the FSM.

My guess is that whatever it is, is basic.
 

·
McTavish
Joined
·
6,416 Posts
I would check the kickstand switch.
Good call!
I had written that off as possibly causal, thinking the fuel pump doesn't prime if the kick stand switch triggers a kill.
So I just did an experiment.
Bike in gear, lean stand down, turn key on.
The fuel pump primed, but the starter won't activate.
I didn't try it with the bike running in gear, clutch in, and put down the lean stand, but my assumption is the engine would be killed, the starter won't activate, and that key off and back on will prime the pump but the starter won't activate.
If the switch and/or related is the culprit that is.
 

·
Super Moderator
Joined
·
11,222 Posts
Might be worth checking the battery. Take it to the auto parts store and have it load tested. Many starting problems reported on here end up being a bad battery. May save you from ripping a lot of stuff apart.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #9 ·
Wow sorry guys didn’t even know anyone replied I’ve been scratching my head for weeks over this been tinkering with it every chance I get and been doing tons of research the I got a bit further than tonight because now it actually runs but like crap and for like 2 seconds the bike is 100% stock other than some slip on mufflers when you turn the key all lights come on all the gauges and fuel pump come on it cranks and spits and sputters but barley it won’t fully turn over you can smell the fuel but the research I’ve been doing has me thinking it could be the FPR going to look into that next
 

·
Premium Member
Joined
·
2,818 Posts
certainly smells like the FPR. replace plugs, see if it will fire off. will run like shit/smoke if it's FPR. Wondering if you might have a stuck injector or 4 as well.
 
1 - 10 of 10 Posts
Top