Side Cover Problems...Help - Wrist Twisters
 
Thread Tools Display Modes
post #1 of 9 Old 01-16-2007, 03:31 PM Thread Starter
 
Join Date: Aug 2006
Posts: 46
Rep Power: 0
 
Side Cover Problems...Help

Hey guys maybe someone can help me out with the side cover problem that I'm having. The two plastic side covers that are located just under the seat are getting pushed out of the rubber grommet. This happens while riding twisties. When I pull my seat off I have to push them back into the rubber grommet. Any advise on how to fix the problem. Thanks Tony

Mountain Road Madness is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 01-16-2007, 03:38 PM
Church of the Holy Smoke
 
MotoCycho's Avatar
 
Join Date: Jan 2006
Location: SLC, UT
Posts: 1,085
Rep Power: 1
 
Quote:
Originally Posted by Mountain Road Madness View Post
Hey guys maybe someone can help me out with the side cover problem that I'm having. The two plastic side covers that are located just under the seat are getting pushed out of the rubber grommet. This happens while riding twisties. When I pull my seat off I have to push them back into the rubber grommet. Any advise on how to fix the problem. Thanks Tony
Yup! I had the same problem. Originally I would make sure that the flat peg thingy was pressed up against the top of the rubber grommet as I tightened the screw. This put tension on the flat peg and helped a bit. Then I found if you actually hold it out of the rubber grommet and slightly higher than the hole while you tighten it, it will have pretty good tension upwards as you can put it back in the hole. Finally I lost one of the rubber grommets. This led me to a far better solution. I replaced the oval shaped rubber grommets with some thicker round ones. As you force them into the holes they take on an oval shape and the opening for the flat peg/tap is a much tighter fit.

Give me a few minutes and I will get some pics posted.

- Rev. CYCHO -

tires.... it's what's for dinner!
MotoCycho is offline  
post #3 of 9 Old 01-16-2007, 03:45 PM Thread Starter
 
Join Date: Aug 2006
Posts: 46
Rep Power: 0
 
Cool I'll hang out here for the pics. man. Thank you very much.

Mountain Road Madness is offline  
post #4 of 9 Old 01-16-2007, 04:04 PM
Church of the Holy Smoke
 
MotoCycho's Avatar
 
Join Date: Jan 2006
Location: SLC, UT
Posts: 1,085
Rep Power: 1
 
Here ya go.

Right side grommet from under the seat:
(looks like this one will need to be replaced soon.)



Left side with side cover pulled away:



Comparison with the Honda oval grommet on the left:




Sorry, I don't know the actual size of these grommets. I have had them in a bin for years. I'm sure you can fine something comparable at a "Home" or auto parts store.

- Rev. CYCHO -

tires.... it's what's for dinner!
MotoCycho is offline  
post #5 of 9 Old 01-16-2007, 04:25 PM Thread Starter
 
Join Date: Aug 2006
Posts: 46
Rep Power: 0
 
Thats a good deal man. Thank you very much. I'll have to go pick some new ones up. Again thanks man.

Mountain Road Madness is offline  
post #6 of 9 Old 01-19-2007, 12:55 PM
 
Join Date: Apr 2006
Posts: 31
Rep Power: 0
 
I'll jump in here real quick - if you ever find the left one missing check your airbox. Mine was gone and found it in there must have been sucked in.

raamhammer is offline  
post #7 of 9 Old 01-20-2007, 05:33 AM Thread Starter
 
Join Date: Aug 2006
Posts: 46
Rep Power: 0
 
Quote:
Originally Posted by raamhammer View Post
I'll jump in here real quick - if you ever find the left one missing check your airbox. Mine was gone and found it in there must have been sucked in.
Thanks for the heads up man. The air intake is in a good spot to suck that right in there.

Mountain Road Madness is offline  
post #8 of 9 Old 01-20-2007, 06:03 AM Thread Starter
 
Join Date: Aug 2006
Posts: 46
Rep Power: 0
 
Little update guys. I took the side covers off of the bike. I drilled a small hole in each tab of the side cover. I reinstalled the covers and installed a small clip pin into each tab. I'll let you guys know how it works. If it works out, I'll post some pictures. Thanks Tony

Mountain Road Madness is offline  
post #9 of 9 Old 01-21-2007, 12:47 PM
Honda Addict
 
razorbike's Avatar
 
Join Date: Jan 2006
Location: Little Rock, AR
Posts: 828
Rep Power: 1
 
Quote:
Originally Posted by Mountain Road Madness View Post
I drilled a small hole in each tab of the side cover. I reinstalled the covers and installed a small clip pin into each tab.
That's a pretty damn good idea MRM!

Had the same problem on mine also. Gonna pin 'em ASAP. That along with Cycho's idea with the grommets and they should stay put.

It's a fool who looks for logic in the chambers of the human heart.
razorbike is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Wrist Twisters forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome