help: intermittent horn - Wrist Twisters
 
Thread Tools Display Modes
post #1 of 5 Old 07-08-2012, 04:13 PM Thread Starter
(-(-(-(-(- -)-)-)-)-)
 
andrewebay1's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 6,883
Rep Power: 1
 
help: intermittent horn

I'm troubleshooting my horn, the switch doesn't seem to have issues but after opening the housing the horn works intermittently. Sprayed it down with wd40 to try to clean the contacts, inspected the cables to the switch (within the housing) all seems well.

I tried another horn, same issue. Anywhere else I should be looking at and how do I fully removed the parts from the housing? I got to this, don't wanna break anything trying to get it out.
Attached Images
File Type: jpg ForumRunner_20120708_161258.jpg (37.5 KB, 12 views)

My classified(s):
Nothing at the moment

----------------
------------
---------
------
---
- '96 Race-retired GSXR 750 (Sold)
- '01 RC51 SP1 (Sold)
- '03 919

"Security is mostly a superstition, it does not exist in nature: avoiding danger in the long run is no safer than outright being exposed. Life is either a daring adventure or nothing."-Helen Keller
andrewebay1 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-08-2012, 04:33 PM
Hastatus Prior
 
TheBeeDeeGee's Avatar
 
Join Date: Sep 2011
Location: Mobile
Posts: 1,570
Rep Power: 1
 
Had this problem on my 599. Check the connections at the horn. I had to replace the connectors.

Sent from my DROID RAZR using Tapatalk 2

"A motorcycle is not just a two-wheeled car; the difference between driving a car and climbing onto a motorcycle is the difference between watching TV and actually living your life."
-2005 CBR 600 F4i
-2001 RC51 ** SOLD
-2002 VFR 800**SOLD
-2002 919 **SOLD
-2006 599 ** WRECKED
TheBeeDeeGee is offline  
post #3 of 5 Old 07-08-2012, 05:12 PM Thread Starter
(-(-(-(-(- -)-)-)-)-)
 
andrewebay1's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 6,883
Rep Power: 1
 
Found the culprit, kinked wire close to the connectors at the horn. Can someone check if the cables are suppose to route around front of the frame or straight down to the horn next to it.

My classified(s):
Nothing at the moment

----------------
------------
---------
------
---
- '96 Race-retired GSXR 750 (Sold)
- '01 RC51 SP1 (Sold)
- '03 919

"Security is mostly a superstition, it does not exist in nature: avoiding danger in the long run is no safer than outright being exposed. Life is either a daring adventure or nothing."-Helen Keller
andrewebay1 is offline  
 
post #4 of 5 Old 07-08-2012, 05:23 PM
The Cripple
 
Pvster's Avatar
 
Join Date: Nov 2009
Location: Phoenix
Posts: 8,770
Rep Power: 1
 
Quote:
Originally Posted by andrewebay1 View Post
Found the culprit, kinked wire close to the connectors at the horn. Can someone check if the cables are suppose to route around front of the frame or straight down to the horn next to it.
straight down the inner side of the frame.

Pvster is offline  
post #5 of 5 Old 07-08-2012, 06:03 PM Thread Starter
(-(-(-(-(- -)-)-)-)-)
 
andrewebay1's Avatar
 
Join Date: May 2009
Location: Seattle, WA
Posts: 6,883
Rep Power: 1
 
Thanks!

My classified(s):
Nothing at the moment

----------------
------------
---------
------
---
- '96 Race-retired GSXR 750 (Sold)
- '01 RC51 SP1 (Sold)
- '03 919

"Security is mostly a superstition, it does not exist in nature: avoiding danger in the long run is no safer than outright being exposed. Life is either a daring adventure or nothing."-Helen Keller
andrewebay1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Wrist Twisters forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome