Fuel Pump Not Priming After PCIII USB Install - Wrist Twisters
 
Thread Tools Display Modes
post #1 of 5 Old 10-25-2014, 11:24 AM Thread Starter
Tirone
 
Mxhonda215's Avatar
 
Join Date: May 2014
Location: Minot
Posts: 37
Rep Power: 1
 
Fuel Pump Not Priming After PCIII USB Install

Yesterday afternoon I finally got around to installing my PCIII usb. After I was all said and done, I went to start it to make sure everything was working properly. I turned the key on and flicked off the kill switch and everything turned on on like normal....except the fuel pump did not prime. I played around with the kill switch (just to make sure it didn't have a bad contact) but still nothing. Has anyone else experienced this problem before? I still need to go through and do some more thorough trouble shooting, but if any of you have an idea on what it could be, let me know. The weather is way to nice to be wasting right now. Thanks guys

Mxhonda215 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-25-2014, 11:36 AM
Tribunus Laticlavius
 
voodooridr's Avatar
 
Join Date: Jan 2006
Location: Salinas, CA
Posts: 4,608
Rep Power: 1
 
Did it start?


Dan
voodooridr is offline  
post #3 of 5 Old 10-25-2014, 12:08 PM Thread Starter
Tirone
 
Mxhonda215's Avatar
 
Join Date: May 2014
Location: Minot
Posts: 37
Rep Power: 1
 
Quote:
Originally Posted by voodooridr View Post
Did it start?
No, it did not. The engine turns over but does not fire

Mxhonda215 is offline  
 
post #4 of 5 Old 10-25-2014, 01:42 PM
Honda919Rider #1
 
Join Date: Sep 2011
Location: USA
Posts: 1,338
Rep Power: 0
 
If it was fine before the install, recheck all connections - especially the connector and the ground.

Does the PCIII show power? When you turn the throttle, lights light up in sequence with the throttle

Steve is offline  
post #5 of 5 Old 10-25-2014, 03:27 PM
Tirone Choolaces
 
marylandmike's Avatar
 
Join Date: Aug 2007
Location: USA
Posts: 11,147
Rep Power: 1
 
Garage

Awards Showcase
Wrist Twisters Event Attendance Donation Donation 
Total Awards: 3

Was the bike in Neutral or the side stand up?

marylandmike is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Wrist Twisters forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome