clicking noise - Wrist Twisters
 
Thread Tools Display Modes
post #1 of 9 Old 09-26-2013, 03:28 PM Thread Starter
Toll Runner
 
str8ghtjacket's Avatar
 
Join Date: May 2006
Location: Hutto
Posts: 1,537
Rep Power: 1
 

Awards Showcase
Extraordinary Ride 
Total Awards: 1

clicking noise

Well not sure what this is but Ill see if anyone here has had this. 07 919- I have this clicking noise, mainly hear it when I pull in the clutch when Im coming to a stop, it might be there all the time but with GEN 1 Satos its hard to tell when Im under throttle. I thought maybe I had a bad link in the chhain but I didnt see anything, really sounds like its under me not behind me, so now Im thinking I need to adjust my clutch, I did put new levers on a few months ago, I didnt notice it before the levers but maybe? I was thinking makbe the brakes too but on the Phobeman stand I didnt hear anything from the back. Again it sounds like its under me. Any thoughts?

str8ghtjacket is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 09-26-2013, 03:35 PM
Tribunus Laticlavius
 
voodooridr's Avatar
 
Join Date: Jan 2006
Location: Salinas, CA
Posts: 4,601
Rep Power: 1
 
mine does it when I start the bike and pull in the clutch to put it 1st gear, kind of a tick tick tick that fades away after a couple seconds, don't know what it is but I first noticed it a couple years ago, can't say if it's been doing it all along or not


Dan
voodooridr is offline  
post #3 of 9 Old 09-26-2013, 03:43 PM
Community Moderator
 
g00gl3it's Avatar
 
Join Date: Jun 2009
Location: Idaho
Posts: 11,614
Rep Power: 1
  

Awards Showcase
Wrist Twisters Event Attendance Wrist Twisters Event Attendance Wrist Twisters Event Attendance 
Total Awards: 3

Injectors.

...on my Droid.

2009 Aprilia Tuono - Ginger
2001 XR650R BRP (Big Red Pig)
2006 Honda 599 - Ex wrecked it :-D
2007 Honda CB900F (sold)
2006 Honda VTX 1300C (sold)
YouTube Channel
g00gl3it is offline  
 
post #4 of 9 Old 09-26-2013, 03:45 PM
The Cripple
 
Pvster's Avatar
 
Join Date: Nov 2009
Location: Phoenix
Posts: 8,765
Rep Power: 1
 
What noise?


Pvster is offline  
post #5 of 9 Old 09-26-2013, 03:55 PM
Tribunus Laticlavius
 
voodooridr's Avatar
 
Join Date: Jan 2006
Location: Salinas, CA
Posts: 4,601
Rep Power: 1
 
str8ghtjacket's might be, I can't hear it from here. Mine's definatly coming from the clutch housing. str8ghtjacket, do you have the factory front rotors? the EBC's I have on mine make a funny whirring/ticking sound when you apply them. I've never heard the injectors make any noise on mine but others have had loud injectors


Dan
voodooridr is offline  
post #6 of 9 Old 09-26-2013, 04:06 PM Thread Starter
Toll Runner
 
str8ghtjacket's Avatar
 
Join Date: May 2006
Location: Hutto
Posts: 1,537
Rep Power: 1
 

Awards Showcase
Extraordinary Ride 
Total Awards: 1

Yeah factory rotors, I never heard the injectors on the 03 I had hmmm weird, Ill try to adjust the clutch and if its not hat I guess maybe Google might be right. Is this a sign there going bad? Any additive I can add like AMS Oil PI or something to clear it up? I really dont remember hearing these do this before the levers but Im not sure I was paying that much attention before now and now Ive heard it I cant not hear it.

str8ghtjacket is offline  
post #7 of 9 Old 09-26-2013, 08:15 PM
Milites Gregarius
 
Join Date: Nov 2012
Location: grand haven
Posts: 139
Rep Power: 1
 
Fuel injectors!!!

littleone231 is offline  
post #8 of 9 Old 09-26-2013, 08:20 PM
Tirone Choolaces
 
marylandmike's Avatar
 
Join Date: Aug 2007
Location: USA
Posts: 11,123
Rep Power: 1
 
Garage

Awards Showcase
Wrist Twisters Event Attendance Donation Donation 
Total Awards: 3

May wanna check your rear wheel bearings. I was getting some clicking at slow speeds when I discovered mine was gone. Sounded a lot like the chain was too loose or something.

marylandmike is offline  
post #9 of 9 Old 09-27-2013, 10:53 AM
Tool & Die
 
morrow919's Avatar
 
Join Date: Sep 2012
Location: NWGA
Posts: 2,187
Rep Power: 1
 

Awards Showcase
Motorcycle Picture Game Award 
Total Awards: 1

An easy way to check and see if it's the levers would be to put your old ones back on. Ride for a bit, and see if it goes away. If so you might can just use some silicon spray on the moving parts of the levers. Just a suggestion.

'07 Hornet - Candy Glory Red
morrow919 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Wrist Twisters forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome