2005 919 FI light - Wrist Twisters
 
Thread Tools Display Modes
post #1 of 11 Old 08-01-2012, 09:22 AM Thread Starter
Tirone
 
Join Date: Aug 2012
Location: Yarmouth
Posts: 11
Rep Power: 1
 
2005 919 FI light

Just wondering if there is anyway to get flash codes for my fuel injection light? The bike will spit and sputter and sometime feel like you turned the ignition off and the FI light will come on then go out and it will work fine for a bit. Its an intermittent problem just wondering if there are any ideas before i drop it to the dealer next week. Love this forum guys, lots of GREAT information!!

CatTech is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 08-01-2012, 11:38 AM
McTavish
 
mcromo44's Avatar
 
Join Date: Oct 2007
Location: Calgary
Posts: 5,802
Rep Power: 1
 
Quote:
Originally Posted by CatTech View Post
Just wondering if there is anyway to get flash codes for my fuel injection light? The bike will spit and sputter and sometime feel like you turned the ignition off and the FI light will come on then go out and it will work fine for a bit. Its an intermittent problem just wondering if there are any ideas before i drop it to the dealer next week. Love this forum guys, lots of GREAT information!!
The codes are in the manual.

mcromo44 is offline  
post #3 of 11 Old 08-01-2012, 11:49 AM
Tirone Choolaces
 
marylandmike's Avatar
 
Join Date: Aug 2007
Location: USA
Posts: 11,147
Rep Power: 1
 
Garage

Awards Showcase
Wrist Twisters Event Attendance Donation Donation 
Total Awards: 3

There is a plug in the tail all the way back on the right side side that you can jumper out and it will help you read any stored codes.
Attached Images
File Type: jpg Service Conn.JPG (60.4 KB, 31 views)

marylandmike is online now  
 
post #4 of 11 Old 08-01-2012, 12:03 PM
Serial Monogamist
 
ST-DocLizard1's Avatar
 
Join Date: Dec 2007
Location: Hampton, NJ
Posts: 1,509
Rep Power: 1
 

Awards Showcase
Wrist Twisters Event Attendance Wrist Twisters Event Attendance Wrist Twisters Event Attendance Wrist Twisters Event Attendance 
Total Awards: 21

Things to remember:

The MIL(malfunction indicator lamp) will start to blink only with the side stand down and the engine off(engine stop switch is set to run) or the engine revs are below 5K. In any other conditions the MIL will illuminate and stay on.

1. Set bike on the side stand and start the engine. Let idle.

2. If the MIL blinks you have a problem to diagnose.

3. The PGM-FI MIL denotes failure codes.(the number of blinks from 0-33). When the indicator lights for 1.3 seconds, it is equivalent to 10 blinks. A blink of 0.5 seconds is one blink. (eg: one long blink and two short blinks equals the code of 12).

4. When more than one failure has occurred, the MIL blinks in the order of the lowest to the highest number.

5. Time start counting and get back to us.

Doc



"FRIENDS DON'T LET FRIENDS EARLY APEX."
ST-DocLizard1 is offline  
post #5 of 11 Old 08-02-2012, 05:29 AM Thread Starter
Tirone
 
Join Date: Aug 2012
Location: Yarmouth
Posts: 11
Rep Power: 1
 
Tried this when i got home and the light will just stay on with no blinking and the bike seems to work fine, my next question is will the ECM log past codes that caused the FI light to come on? So if i bring it to the dealer will he see past codes? Thanks for your patience!

CatTech is offline  
post #6 of 11 Old 08-02-2012, 06:42 AM
Serial Monogamist
 
ST-DocLizard1's Avatar
 
Join Date: Dec 2007
Location: Hampton, NJ
Posts: 1,509
Rep Power: 1
 

Awards Showcase
Wrist Twisters Event Attendance Wrist Twisters Event Attendance Wrist Twisters Event Attendance Wrist Twisters Event Attendance 
Total Awards: 21

If there are no blinks, the MIL stays lit, and the engine operates normally; the possible causes are:

1. Short circuit in the service connector.

2. Faulty ECM.

3. Short circuit in the service connector wire.



"FRIENDS DON'T LET FRIENDS EARLY APEX."
ST-DocLizard1 is offline  
post #7 of 11 Old 08-02-2012, 07:26 AM Thread Starter
Tirone
 
Join Date: Aug 2012
Location: Yarmouth
Posts: 11
Rep Power: 1
 
Will the ECM log past codes?

CatTech is offline  
post #8 of 11 Old 08-02-2012, 07:26 AM
Tirone Choolaces
 
marylandmike's Avatar
 
Join Date: Aug 2007
Location: USA
Posts: 11,147
Rep Power: 1
 
Garage

Awards Showcase
Wrist Twisters Event Attendance Donation Donation 
Total Awards: 3

You didn't recently install a fender eliminator or something else that would cause to to drill up through the under tail did you?

marylandmike is online now  
post #9 of 11 Old 08-02-2012, 07:27 AM
Tirone Choolaces
 
marylandmike's Avatar
 
Join Date: Aug 2007
Location: USA
Posts: 11,147
Rep Power: 1
 
Garage

Awards Showcase
Wrist Twisters Event Attendance Donation Donation 
Total Awards: 3

Quote:
Originally Posted by CatTech View Post
Will the ECM log past codes?
Yes read post #3

marylandmike is online now  
post #10 of 11 Old 08-02-2012, 07:33 AM Thread Starter
Tirone
 
Join Date: Aug 2012
Location: Yarmouth
Posts: 11
Rep Power: 1
 
Bike is 100% stock, ok sorry i see in post 3. The problem comes and goes and by the time i got home tuesday night it was working good with no lights. It took me an hour to go 20 miles, would run fine then just spit sputter and red FI light would come on, happened about 15 times in 60 min. Now that its home in the garage it worked fine last night. Thanks for your help Cant get into the Honda dealer till next friday so im trying a few things on my own.

CatTech is offline  
post #11 of 11 Old 09-11-2012, 08:20 AM Thread Starter
Tirone
 
Join Date: Aug 2012
Location: Yarmouth
Posts: 11
Rep Power: 1
 
Hey guys sorry for the delay in response, in the end i found the problem to be with an alarm system the previous owner installed. He had hacked into the honda harness and didnt use shrinktube or any other sealing agent so it had turned green on me. Thanks for your input guys

CatTech is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Wrist Twisters forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome