2002 919 fuel pump not priming, tried the usual stuff already - Wrist Twisters
 
Thread Tools Display Modes
post #1 of 4 Old 05-24-2017, 10:05 PM Thread Starter
Tirone
 
Join Date: May 2017
Posts: 3
Rep Power: 1
 
2002 919 fuel pump not priming, tried the usual stuff already

So a bit of a backstory here... Got this bike as a bit of a basket case from a buddy of mine. Long story short it was his daily until it got stolen, he got another bike, then this one was recovered and with something else to ride he tore it apart for a project that never happened. The thieves cut the ignition cylinder, fuse box, and some other random bits (like the PAIR valve... WHY?!).
Anyway like the title says the fuel pump won't prime. The bike kicks over, lights turned on when I had them hooked up, but no fire.
So, so far...

-Pink wire from ign. is within spec, tested both at the ignition side and the ECU side.
-Fuel relay tested OK with multimeter both with bench power source and on the bike. Also tried swapping around with the other 2 relays on the harness and no change.
-Clutch has been tried with the proper (broken) perch, a new perch, and jumped together.
-Kickstand has been tried both up and down (bike always in neutral).
-Bank angle sensor tests OK, and I also tried one off a 929 just in case.
-Run/stop switch IS functioning properly. Yes, I'm triple sure.
-Pump runs when jumped to 12v. Bike still does not start when cranking with the fuel pump hotwired.
-ECU *seems* fine.

I currently have everything hooked up and seemingly proper with the exception of the head/tail lights and the PAIR valve. Also of note is that I'm using the ignition cylinder off a 929 while waiting for a new 919 ignition to arrive... but, again, the voltage at the pink wire is within spec.
I'm stumped as to where to look next, and I'd really like to get this thing going as I have a trade lined up I'd really like to get my hands on. You guys have any thoughts?

mcantar is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-24-2017, 10:42 PM
Tesserarius
 
nathanktm's Avatar
 
Join Date: Oct 2013
Location: Floral Park
Posts: 619
Rep Power: 1
 

Awards Showcase
Wrist Twisters Event Attendance Wrist Twisters Event Attendance Wrist Twisters Event Attendance Wrist Twisters Event Attendance 
Total Awards: 6

U checked for spark?

Sent from my SM-G920P using Tapatalk

nathanktm is offline  
post #3 of 4 Old 05-24-2017, 11:10 PM Thread Starter
Tirone
 
Join Date: May 2017
Posts: 3
Rep Power: 1
 
Ya know, I've been so focused on chasing down this fuel pump thing I hadn't even thought about spark. Just went and checked with an old plug on the #1 cyl wire and saw no spark at the gap. Interesting.
Hmmm.... ECU maybe? I'll do some more poking and prodding tomorrow. Wish I could find a halfway decent wiring diagram for these bikes.

mcantar is offline  
 
post #4 of 4 Old 05-27-2017, 04:03 PM
Tirone
 
Join Date: Dec 2015
Posts: 31
Rep Power: 1
 
Quote:
Originally Posted by mcantar View Post
Ya know, I've been so focused on chasing down this fuel pump thing I hadn't even thought about spark. Just went and checked with an old plug on the #1 cyl wire and saw no spark at the gap. Interesting.
Hmmm.... ECU maybe? I'll do some more poking and prodding tomorrow. Wish I could find a halfway decent wiring diagram for these bikes.
I just got through with my own similar problem - fuel pump wouldn't prime, but I did have spark. In my case it turns out the ECM was fried by a short-circuit, but I don't know if that's your issue here.

If you haven't found it yet, check out Rob's post here, it is worth its weight in gold.

hypnotichatt is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Wrist Twisters forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome