Cbr900rr 919 1996 - Wrist Twisters
 
Thread Tools Display Modes
post #1 of 2 Old 08-23-2019, 08:04 AM Thread Starter
Tirone
 
Andy Colegate's Avatar
 
Join Date: Jun 2019
Posts: 1
Rep Power: 1
 
Cbr900rr 919 1996

Hi I'm after some advice concerning my clutch, new clutch recently fitted and new cable, for some reason I have no adjustment on the cable and the clutch is dragging, any ideas please 😁Thanks in advance

Andy Colegate is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-23-2019, 03:14 PM
Left of Centre
 
K1w1Boy's Avatar
 
Join Date: May 2011
Location: Auckland, NZ
Posts: 3,505
Rep Power: 1
 
Can you ensure that the cable is the correct one for your bike? Sounds like the relative lengths of the cable inner and outer are off - the inner wire part is too long, and you can't adjust the length out of it to get enough pull on the clutch to get it to clear the plates, hence the dragging.

K1w1Boy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Wrist Twisters forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome